Campaign Manager: List upload issue
Incident Report for Optus
Resolved
We are now marking this issue as fully resolved.

We have seen no repeat of the earlier issue since the fix was implemented last night at 16:30 AEDT (05:30 UTC), we have also had no further reports of any issues from our clients.

If you require further information or are still encountering issues with Campaign Manager, please contact our support team.

Regards,

Optus SMS Support Team
Posted Dec 16, 2022 - 08:53 AEDT
Monitoring
The issue affecting Campaign Manager was resolved at approx 16:30 AEDT (05:30 UTC)

The affected error reporting functionality when uploading new Campaign Manager Lists has been restored and users are again able to view an error report for any rows that failed to upload.

Our team will monitor the system and we will resolve this incident once we have seen normal behaviour for an extended period

If you require further information, please contact our support team.

Regards,

Optus SMS Support Team
Posted Dec 15, 2022 - 20:07 AEDT
Identified
Hello everyone,

Thank you for your patience. We have made a change to our Campaign Manager service to fix the underlying issue. When uploading a csv file, Campaign Manager now accurately reflects the number of rows uploaded successfully.

Please note: Email notifications that inform customers of any errors while uploading files continues to be investigated and we hope to resolve this over the next few days. As a workaround, customers can continue to upload csv files to Campaign Manager, and then download that same list, to find out which rows within your file have errors.

We apologise for the inconvenience this may cause.

To help, here is a link to avoid errors when uploading a list https://confluence.modicagroup.com/display/OPTUS/Campaign+Manager+User+Guide#expand-YourGuidetoCSVFileFormatting

The Campaign Manager service is otherwise working as expected.

If you are still experiencing issues uploading your csv file, please email support@modicagroup.com

Thank you for your continued patience.

Regards,


Optus SMS Support Team
Posted Dec 15, 2022 - 15:17 AEDT
Investigating
We are investigating a bug with the campaign manager having issues when uploading a .csv file as a list.
Campaign manager users are no longer receiving email notifications that contain information about the list upload errors and so users are unable to fix the errored rows to re-upload the .csv file as a list.

However, the campaign manager will successfully upload the rows that did not error and campaigns can be sent to the successfully uploaded rows with member information.

Campaign manager users are recommended to follow the below guide when uploading a list to avoid errors >> https://confluence.modicagroup.com/display/OPTUS/Campaign+Manager+User+Guide#expand-YourGuidetoCSVFileFormatting

Our development team is working on a fix and we should have an ETA soon.
If you have any questions or concerns kindly send an email to support@modicagroup.com

Thank you
Modica Support
Posted Dec 15, 2022 - 11:23 AEDT
This incident affected: Applications (Campaign Manager).